Fix pour bug MOD


#1

Salut les gars,

Afin de remmettre nos mods sur le serveur, j’ai trouvé une solution pour ceux qui ont des soucis de mod sur le serveur après une installation propre de squad !

Si vous avez installé Squad pour la première fois (par exemple après une installation propre de Windows) et que vous installez un Squad Mod, vous pouvez constater que vous ne pouvez pas rejoindre un serveur exécutant ce mod, mais que d’autres peuvent le faire. La raison en est que la clé de registre contenant le chemin d’installation Squad n’est plus créée à cet emplacement dans le registre.

Pour corriger cela (il s’agit d’un contournement temporaire jusqu’à ce qu’il soit corrigé dans Squad), vous devez créer manuellement l’“ancienne” clé de registre.

Si Squad est installé à l’emplacement par défaut ::

  • C:\Program Files (x86)\Steam\steamapps\common\Squad

alors vous n’avez qu’à télécharger le fichier reg suivant, décompresser et l’exécuter :

Squad_a-11-0_Modding_Hotfix.zip ICI

Si Squad est installé dans un endroit différent comme

  • D:\SteamLibrary\steamapps\common\Squad

vous devez ouvrir le fichier reg-file (clic droit et choisir “Edit”) et changer le “install_path” à partir de :

  • “install_path”=“C:\Program Files (x86)\Steam\steamapps\common\Squad”

En

  • “install_path”=“D:\SteamLibrary\steamapps\common\Squad”
    (notez bien qu’il y a des backslashes \ )

pour que le contenu du fichier ressemble à ceci :

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\OffworldIndustries]

[HKEY_CURRENT_USER\Software\OffworldIndustries\Squad]
“install_path”=“D:\SteamLibrary\steamapps\common\Squad”

Sauvegardez le fichier et exécutez-le. Vos mods devraient à nouveau fonctionner correctement !

Bon courage !